Re: FSM Enhancement Goals and Thoughts


Subject: Re: FSM Enhancement Goals and Thoughts
From: Stefen Boyd (stefen@boyd.com)
Date: Tue Dec 11 2001 - 17:54:56 PST


At 04:45 PM 12/11/2001 -0800, you wrote:
>enum_onehot
>enum_state_onehot
>
>Waveform viewers would now treat the onehot enumeration as an index as
>opposed to an actual encoding.
>
>Probably would also require:
>
>case_onehot(state)
> IDLE: ... ->> S0; // treated the same as:
>// case(1'b1)
>// state[IDLE]: ... next[S0] = 1'b1;

Cliff,

I like the idea of changing the name to avoid the
common name "state". But it would seem that although
we may use an enum_state with "case()", it will most likely
be used for "transition()"

So why not make the new transition() statement
behave differently for enum_state and enum_state_onehot?
That way, we're down to only one change... and it
won't be too weird since the transition statement is
also new to have one that automagically does the
verilog reverse-case style.

I would still love to see a solution to the asychronous
reset problem.

Stefen

--------------------
Stefen Boyd Boyd Technology, Inc.
stefen@BoydTechInc.com (408)739-BOYD
www.BoydTechInc.com (408)739-1402 (fax)



This archive was generated by hypermail 2b28 : Tue Dec 11 2001 - 17:56:15 PST